Задать вопрос
8 апреля, 11:48

Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0

+1
Ответы (1)
  1. 8 апреля, 15:13
    0
    uses crt;

    var a:array[1 ... 20] of integer;

    i, max:integer;

    begin

    clrscr;

    for i:=1 to 5 do

    begin

    readln (a[i]) ;

    max:=0;

    if (a[i] div 100>0) and

    (a[i] mod 10=0) and (a[i]>max)

    then max:=a[i];

    end;

    writeln ('max=', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от - 1000 до 1000 включительно. Опишите алгоритм, позволяющий найти и вывести минимальное значение среди отрицательных элементов массива, оканчивающихся на 3.
Ответы (1)
Помогите написать программу на паскале Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от - 10000 до 10000 включительно.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан целочисленный массив из 40 элементов элементы массива могут принимать целые значения от 1 до 10000 включительно.
Ответы (1)
Опишите на естественном языке или на одном из языков программирования алгоритм, позволяющий найти и вывести минимальное значение среди трёхзначных элементов массива, делящихся на 7. (паскаль)
Ответы (2)