Задать вопрос
22 сентября, 10:31

Дан целочисленный массив из 40 элементов элементы массива могут принимать целые значения от 1 до 10000 включительно. Опишите на естественном или на одном из языков программирования алгоритм, позволяющий найти и вывести наименьший из элементов массива, шестнадцатеричная запись которого содержит ровно две цифры. Если таких чисел нет, то нужно вывести ответ 0.

+3
Ответы (1)
  1. 22 сентября, 14:05
    0
    Var min, i:integer;

    a:array[1 ... 40]of integer;

    begin

    min:=10001;

    writeln ('Введите значения элементов массива') ;

    for i:=1 to 40 do begin

    readln (a[i]) ;

    if (a[i] div 16 >9) and (a[i] div 16 < 99) and (a[i]
    end;

    if (min10001) then writeln ('Минимальное значение:', min) else writeln (0) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный массив из 40 элементов элементы массива могут принимать целые значения от 1 до 10000 включительно. Опишите на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу на паскале Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые значения от - 10000 до 10000 включительно.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от - 1000 до 1000 включительно. Опишите алгоритм, позволяющий найти и вывести минимальное значение среди отрицательных элементов массива, оканчивающихся на 3.
Ответы (1)
Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно.
Ответы (1)
Дан целочисленный массив из 10 элементов. Элементы массива могут принимать целые значения от 0 до 1000.
Ответы (1)