Задать вопрос
11 сентября, 19:30

Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину. программу нужно написать в паскале

пример, как должно получиться

введите координаты точки а

5.5 3.5

введите координаты точки b

1.5 2

длинна отрезка ab=4.272

+2
Ответы (1)
  1. 11 сентября, 19:45
    0
    Var

    x1, x2, y1, y2:real;

    begin

    writeln ('Введите координаты первой точки (х1, у1) ') ;

    readln (x1, y1) ;

    writeln ('Введите координаты второй точки (х2, у2) ') ;

    readln (x2, y2) ;

    writeln (sqrt (sqr (x2-x1) + sqr (y2-y1)) : 3:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину. программу нужно написать в паскале пример, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести с клавиатуры координаты двух точек (а и в) на плоскости (вещественный числа). вычислить длину отрезка АВ. программу нужно написать в паскале
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)