Задать вопрос
26 марта, 01:21

1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c)

2. Координаты 2-х точек плоскости вводятся с клавиатуры. Определите и выведите на экран какая точка расположена дальше от начала координат и на сколько.

Формат вывода следующий "Расстояние от точки А до начала координат больше, чем расстояние от точки В до начала координат на 8,5 единиц"

Проведите тестирование программы для точек из разных четвертей координатной плоскости.

+5
Ответы (1)
  1. 26 марта, 03:54
    0
    1. var a, b, c:integer;

    d, x1, x2:real;

    begin;

    readln (a) ;

    readln (b) ;

    readln (c) ;

    d:=sqr (b) - 4*a*c;

    if d<0 then

    writeln ('Нет корней')

    else

    if d=0 then

    begin;

    x1:=-b / (2*a) ;

    writeln (x1) ;

    end

    else

    begin;

    x1: = (-b+sqrt (d)) / (2*a) ;

    x2: = (-b-sqrt (d)) / (2*a) ;

    writeln (x1) ;

    writeln (x2) ;

    end;

    end.

    2) var x1, y1, x2, y2:integer;

    r1, r2, rr:real;

    begin;

    readln (x1) ;

    readln (y1) ;

    readln (x2) ;

    readln (y2) ;

    r1:=sqrt (sqr (x1) + sqr (y1)) ;

    r2:=sqrt (sqr (x2) + sqr (y2)) ;

    if r1>r2 then

    begin;

    rr:=r1-r2;

    write ('Расстояние от точки А до начала координат больше, чем расстояние от точки В до начала координат на ', rr,' единиц') ;

    end

    else

    if r1
    begin;

    rr:=r2-r1;

    write ('Расстояние от точки B до начала координат больше, чем расстояние от точки A до начала координат на ', rr,' единиц') ;

    end

    else

    write ('Точки A и B равноудалены от начала координат') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
На языке питон Даны два целых числа. Программа должна вывести число 1, если первое число больше второго, число 2, если второе больше первого или число 0, если они равны. Формат ввода Вводятся два целых числа. Формат вывода Выведите ответ на задачу.
Ответы (2)