Задать вопрос
7 июля, 16:16

1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его.

2. Ввести три вещественных числа с клавиатуры. Выдать на экран сумму положительных чисел и сумму отрицательных чисел.

+2
Ответы (1)
  1. 7 июля, 19:21
    0
    Var

    X, Y, X1, Y1, Z1:real;

    Begin

    WriteLn ('Размеры двери:') ;

    ReadLn (X, Y) ;

    WriteLn ('Размеры шкафа:') ;

    ReadLn (X1, Y1, Z1) ;

    if

    ((X>=X1) and (Y>=Y1)) or

    ((X>=X1) and (Y>=Z1)) or

    ((X>=Y1) and (Y>=X1)) or

    ((X>=Y1) and (Y>=Z1)) or

    ((X>=Z1) and (Y>=X1)) or

    ((X>=Z1) and (Y>=Y1)) then Write ('Можно')

    else Write ('Нельзя')

    End.

    Var

    A, B, C:real;

    Sp, So:real;

    Begin

    Sp:=0;

    So:=0;

    WriteLn ('Введите три числа') ;

    ReadLn (A, B, C) ;

    if A<0 then So:=So+A

    else Sp:=Sp+A;

    if B<0 then So:=So+B

    else Sp:=Sp+B;

    if C<0 then So:=So+C

    else Sp:=Sp+C;

    WriteLn ('Сумма положительных равна ', Sp) ;

    WriteLn ('Сумма отрицательных равна ', So) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатику. Ввести 2 числа, найти их сумму и произведение, если произведение окажется положительным, то выдать его на экран, а иначе выдать на экран сумму.
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
С клавиатуры ввели 10 чисел положительных и отрицательных. необходимо вывести на экран сумму всех положительных чисел
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)