Задать вопрос
10 декабря, 23:23

2) Написать программу вычисления площади треугольника, если известны длины двух сторон и величина угла между этими сторонами. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).

Вычисление площади треугольника.

Введите (через пробел) длины двух сторон (см) треугольника

= 25 17

Введите величину угла между сторонами треугольника

= 30

Площадь треугольника: 106.25 кв. см.

+3
Ответы (1)
  1. 11 декабря, 01:45
    0
    Var

    a, b, alpha, s:real;

    begin

    writeln ('Вычисление площади треугольника') ;

    writeln ('Введите (через пробел) длины двух сторон (см) треугольника') ;

    readln (a, b) ;

    writeln ('Введите величину угла (градус) между сторонами треугольника') ;

    readln (alpha) ;

    alpha:=DegToRad (alpha) ;

    writeln ('Площадь треугольника: ',0.5*a*b*sin (alpha),' кв. см.')

    end.

    Тестовое решение:

    Вычисление площади треугольника

    Введите (через пробел) длины двух сторон (см) треугольника

    25 17

    Введите величину угла (градус) между сторонами треугольника

    30

    Площадь треугольника: 106.25 кв. см.

    Вычисление площади треугольника

    Введите (через пробел) длины двух сторон (см) треугольника

    11 16.3

    Введите величину угла (градус) между сторонами треугольника

    39

    Площадь треугольника: 56.4185730576179 кв. см.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2) Написать программу вычисления площади треугольника, если известны длины двух сторон и величина угла между этими сторонами. Ниже ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Turbo Pascal Написать программу вычисления объема цилиндра. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление объема цилиндра.
Ответы (1)
Написать программу вычисления расстояния между населенными пунктами, изображенными на карте. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Ответы (1)
Написать программу вычисления стоимости некоторого количества (по весу) яблок. Нижепредставлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление стоимости покупки.
Ответы (1)
Написать программу вычисления стоимости некоторого количества (по весу) яблок. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом). Вычисление стоимости покупки.
Ответы (1)
Составьте блок-схему и прогроамму на языке PascalABC для вычисления площади прямоугольника. Рекомендуемый вид экрана во время работы приведён ниже (данные, введённые пользователем выделены полужирным шрифтом).
Ответы (1)