Задать вопрос
31 мая, 12:59

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.

На вход программе сначала подается значение n<=100 - количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива - целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

+2
Ответы (1)
  1. 31 мая, 13:10
    0
    Var

    a:array [1 ... 100] of integer;

    i, n, k, mx:integer;

    begin

    writeln ('Введите n:') ;

    readln (n) ;

    mx:=1; k:=0;

    writeln ('Введите массив:') ;

    for i:=1 to n do

    begin

    readln (a[i]) ;

    if a[i]>a[mx] then

    begin

    mx:=i;

    k:=0;

    end else

    if (a[i]=a[mx]) and (imx) then k:=k+1;

    end;

    writeln ('Количество элементов массива равных максимальному: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу. На вход программе сначала подается значение n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Подсчитайте за один проход массива, сколько его элементов равны максимальному элементу. Входные данные На вход программе сначала подается значение n100 - количество элементов в массиве.
Ответы (1)
Pascal ABC На вход программе подаётся последовательность температур за каждый день ноября. Первой строкой подаётся количество таких записей. Найти количество дней ноября, когда были заморозки (температура опускалась ниже 0).
Ответы (1)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Числа Фибоначчи определяются следующими формулами: f0=f1=1; fn=fn-1+fn-2, при n>=2 на вход программе подается целое неотрицательное n=
Ответы (1)
Вход: 12 выход: 21; вход: школа выход: не могу; вход: 25 выход: 47; вход: 137 выход: 271. Какое правило?
Ответы (1)