Задать вопрос
31 мая, 11:51

Составить программу на Паскале с помощью цикла с неизвестным числом повторений. "На первый же день появления красавца Васи в колледже в него влюблялись 2 девочки. С каждым днем их число увеличивалось в два раза, но каждую неделю 23 девочки разочаровывались в нем и влюблялись в Сережу. Через сколько дней в Васю влюбятся 45 девочек?"

+1
Ответы (1)
  1. 31 мая, 12:49
    0
    Var k, n:integer;

    begin

    n:=1;

    k:=2;

    while k<=45 do

    begin

    n:=n+1;

    k:=k*2;

    if n mod 7 = 0 then k:=k-23;

    end;

    writeln ('n = ', n,' k = ', k) ;

    end.

    Результат:

    n = 6 k = 64
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на Паскале с помощью цикла с неизвестным числом повторений. "На первый же день появления красавца Васи в колледже в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней? Составить программу в паскале помощью цикла repeat.
Ответы (2)
Проанализируйте работу программы. program math; var x, y: integer; begin x:=1; y:=1; while x
Ответы (1)