Задать вопрос
28 мая, 14:33

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней? Составить программу в паскале помощью цикла repeat.

+1
Ответы (2)
  1. 28 мая, 16:14
    0
    Program pr; var norma, total:real; day:integer; begin norma:=10; day:=0; repeat day:=day+1; writeln ('День: ', day) ; writeln ('Норма: ', norma:0:1,' км') ; writeln () ; total:=total+norma; norma:=norma*1.1; until day=7; writeln () ; writeln ('Всего: ', total:0:1) ; end.
  2. 28 мая, 16:32
    0
    Var

    d:integer;

    n, s:real;

    begin

    n:=10;

    s:=10; {путь в первый день, считать будем поэтому со второго дня}

    d:=2;

    repeat

    n:=n * (1+0.1) ;

    s:=s+n;

    d:=d+1;

    until d>7;

    writeln (s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Начав тренировки, спортсмен пробежал в первый день 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Сколько он пробегал за каждый день тренировки? Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)
Нужно в паскале ABS Начав тренировки спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)
Начав тренировки спортсмен в первый день пробежал 10 км. Каждый следущий день он увеличивал дневную норму на 8% от нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за n дней?
Ответы (1)
начав тренировки, спортсмен в 1 день пробежал 10 км. каждый день он увеличивал дневную норму бега на 10% нормы предыдущего дня. какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (2)
Составит блок - схему и программу начав тренировки спортсмен пробежал 10 км, каждый следующий день увеличивал дневную норму на 10% от нормы предыдущего дня. Какую сумарную путь пробежал за 7 дней?
Ответы (1)