Задать вопрос
7 июня, 14:11

Подсчитайте за один проход массива, сколько его элементов равны максимальному элементу.

Входные данные

На вход программе сначала подается значение n100 - количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива - целые числа, по модулю не превосходящие 30 000.

Выходные данные

Выдайте количество искомых элементов массива.

Примеры

входные данные

8

4 3 5 2 5 1 3 5

выходные данные

3

+5
Ответы (1)
  1. 7 июня, 17:23
    0
    Var

    A:array[1 ... 100] of integer;

    i, M, N, k:integer;

    Begin

    ReadLn (N) ;

    M:=-30001;

    k:=0;

    For i: = 1 to N do

    Begin

    Read (A[i]) ;

    if A[i]>M then

    Begin

    k:=0;

    M:=A[i]

    End;

    if A[i]=M then k:=k+1

    End;

    WriteLn (k)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Подсчитайте за один проход массива, сколько его элементов равны максимальному элементу. Входные данные На вход программе сначала подается ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу. На вход программе сначала подается значение n
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Python! Напишите программу, которая находит в массиве количество элементов, равных максимальному. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)