Задать вопрос
7 февраля, 15:56

Решить в Паскале:

определить количество перемен знака у элементов заданного вектора из М элементов

+5
Ответы (1)
  1. 7 февраля, 19:04
    0
    Var

    i, k:integer;

    a:array[1 ... 10]of integer;

    begin

    write ('Массив: ') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (-10,10) ;

    write (a[i],' ') ;

    end;

    writeln;

    for i:=1 to 9 do

    begin

    if a[i]*a[i+1]<0 then k:=k+1

    end;

    writeln ('Число перемен знака: ', k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в Паскале: определить количество перемен знака у элементов заданного вектора из М элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10.
Ответы (1)
Вычислить X=m / (n-m), где m - сумма квадратов отрицательных элементов первого вектора, n - сумма квадратов отрицательных элементов второго вектора в паскале
Ответы (1)
Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом) p. s. В паскале
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)