Задать вопрос
18 апреля, 08:09

1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа.

2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа.

3. Для заданного действительного числа К вычислить значение произведения

(99/k^3-98) * (97/k^3+96) * (95/k^3-94) * ... * (3/k^3+2)

+3
Ответы (1)
  1. 18 апреля, 09:42
    0
    1. var a, s:integer;

    begin

    writeln ('введи 3-значное число') ;

    readln (a) ;

    if (a>99) and (a<1000) then begin

    while a>0 do

    begin

    s:=s+sqr (a mod 10) ;

    a:=a div 10;

    end;

    writeln (s) ;

    end else writeln ('Ошибка ввода') ;

    end.

    2. var a, s, k:longint;

    begin

    writeln ('введи 8-значное число') ;

    readln (a) ;

    if (a>9999999) and (a<100000000) then begin

    while a>0 do

    begin

    k: = a mod 10;

    s:=s-k*k*k;

    a:=a div 10;

    end;

    writeln (s) ;

    end else writeln ('Ошибка ввода') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если трёхзначное число равно сумме кубов цифр, образующих это число, то такое число называется "магическим". Найти и вывести все "магические числа". (Написать функцию вычисления суммы кубов цифр трёхзначного числа).
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. 2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители заданного числа
Ответы (1)