Задать вопрос
15 марта, 11:38

Если трёхзначное число равно сумме кубов цифр, образующих

это число, то такое число называется "магическим". Найти и вывести все

"магические числа". (Написать функцию вычисления суммы кубов цифр

трёхзначного числа). Паскаль, через функции пользователя.

+1
Ответы (1)
  1. 15 марта, 13:19
    0
    Var i:integer;

    function sum (n:integer) : integer;

    var n1, n2, n3:integer;

    begin

    n1:=n div 100;

    n2:=n div 10 mod 10;

    n3:=n md 10;

    sum:=n1*n1*n1+n2*n2*n2+n3*n3*n3;

    end;

    begin

    writeln ('Магические числа:') ;

    for i:=100 to 999 do

    if i=sum (i) then writeln (i) ;

    end.

    Результат:

    Магические числа:

    153

    370

    371

    407
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Если трёхзначное число равно сумме кубов цифр, образующих это число, то такое число называется "магическим". Найти и вывести все ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)