Задать вопрос
19 августа, 17:54

1. составить программу и алгоритм находящую сумму цифр трехзначного числа

2. составить программу и алгоритм находящую все простые делители заданного числа

+3
Ответы (1)
  1. 19 августа, 18:21
    0
    Program gt;

    var s, a, b, c, n:longint;

    begin

    read (n) ;

    a:=n div 100;

    b: = (n mod 100) div 10;

    c:=n mod 10;

    s:=a+b+c;

    writeln (s) ;

    end.

    2)

    program gt;

    label 1;

    var p, n, i, j:longint;

    begin

    read (n) ;

    for i:=2 to n do

    begin

    if (n mod i=0) then begin

    p:=round (sqrt (i)) ;

    for j:=2 to p do

    begin

    if (i mod j=0) then goto 1;

    end;

    writeln (i) ;

    1:

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)