Задать вопрос
22 мая, 16:39

Помогите сделать задачи в Pascal ABC.

1. Даны два неотрицательных числа a и b. Найти их среднее геометрическое, т. е. квадратный корень из их произведения: (a*b) 1/2 (1/2 это степень).

2. Даны два ненулевых числа. Найти сумму, разность, произведение и частное их модулей.

3. Даны два круга с общим центром и радиусами R1 и R2 (R1>R2). Найти площади этих кругов S1 и S2, а также площадь S3 кольца, внешний радиус которого равен R1, а внутренний радиус равен R2: S1=п * (R1) ^2, S2=п * (R2) ^2, S3=S1 - S2. В качестве значения п использовать 3.14.

4. Дана площадь S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L=п*D, S=п*D^2/4. В качестве значения п использовать 3.14.

+3
Ответы (1)
  1. 22 мая, 19:09
    0
    1. var a, b, c:real;

    begin

    readln (a, b) ;

    c:=sqrt (a*b) ;

    writeln ('Среднее геометрическое = ', c)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите сделать задачи в Pascal ABC. 1. Даны два неотрицательных числа a и b. Найти их среднее геометрическое, т. е. квадратный корень из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в паскале. Дана площадь S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = 2·π·R, S = π·R^2 . В качестве значения π использовать 3.14.
Ответы (1)
Помогите решить) Begin11 ° (В №3). Даны два ненулевых числа. Найти сумму, разность, произведение и частное их модулей. Входные данные: ввести два целых числа а и b (1
Ответы (1)
Написать программу на Паскале: Дана S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = π*D, S = π*D2 (в квадрате) / 4
Ответы (1)
Всё надо сделать на паскале. a) x^5 b) x^6 c) x^8 d) x^9 e) x^10 2 задание: Дан диаметр окружности d. Найти его длину (L=П*d) 3 задание: Найти длину окружности L и площадь круга S заданного радиуса R: L=2πR, S = πR^2 4 задание: Даны 2 числа a и b.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)