Задать вопрос
13 мая, 03:31

Написать программу на Паскале: Дана S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = π*D, S = π*D2 (в квадрате) / 4

+2
Ответы (1)
  1. 13 мая, 04:34
    0
    const

    pi = 3.14;

    var

    S, D, L: real;

    begin

    write ('Введите площадь круга: S = ') ;

    readln (S) ;

    D : = 2 * sqrt (S / pi) ; { < - - Вычисляем диаметр круга }

    L : = pi * D; { < - - Вычисляем длину окружности }

    writeln ('Результат:') ;

    writeln (' D = ', D:0:2) ; { < - - Выводим диаметр на экран }

    writeln (' L = ', L:0:2) ; { < - - Выводим длину на экран }

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале: Дана S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = π*D, S = ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в паскале. Дана площадь S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = 2·π·R, S = π·R^2 . В качестве значения π использовать 3.14.
Ответы (1)
Составить программу через Pascal ABC. Дана длина L окружности. Найти ее радиус R и площадь S круга, ограниченного этой окружностью, учитывая, что L = 2*Pi*R, S = Pi*R2 (R в квадрате). Pi = 3.14 P. S Напишите полную программу
Ответы (1)
Решить задачу на Паскале. Заданы площади круга S1 и квадрата S2. Определить поместится ли круг в квадрате. Задачу решить при а) S1=70, S2=36,74 б) S1=0,86, S2=0,64 Квадрат поместится в круге, если диаметр окружности меньше или равен стороне квадрата.
Ответы (1)
Всё надо сделать на паскале. a) x^5 b) x^6 c) x^8 d) x^9 e) x^10 2 задание: Дан диаметр окружности d. Найти его длину (L=П*d) 3 задание: Найти длину окружности L и площадь круга S заданного радиуса R: L=2πR, S = πR^2 4 задание: Даны 2 числа a и b.
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)