Задать вопрос
29 августа, 12:26

Написать программу в паскале.

Дана площадь S круга. Найти его диаметр D и длину L окружности,

ограничивающей этот круг, учитывая, что L = 2·π·R, S = π·R^2

. В качестве

значения π использовать 3.14.

+3
Ответы (1)
  1. 29 августа, 13:00
    0
    Program qwer;

    uses crt;

    var s, r, d, l: real;

    Begin

    write ('Площадь круга: ') ;

    readln (s) ;

    r : = sqrt (s / 3.14) ;

    d : = r * 2; l : = 2 * 3.14 * r;

    writeln ('Диаметр: ', d) ;

    writeln ('Длина окружности: ', l) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале. Дана площадь S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу на Паскале: Дана S круга. Найти его диаметр D и длину L окружности, ограничивающей этот круг, учитывая, что L = π*D, S = π*D2 (в квадрате) / 4
Ответы (1)
Помогите сделать задачи в Pascal ABC. 1. Даны два неотрицательных числа a и b. Найти их среднее геометрическое, т. е. квадратный корень из их произведения: (a*b) 1/2 (1/2 это степень). 2. Даны два ненулевых числа.
Ответы (1)
Дана длина L окружности. Найти ее радиус R и площадь S круга, ограниченного этой окружностью, учитывая, что L = 2*Pi*R, S = Pi*R2. В качестве значения Pi использовать 3.14. В паскале, код нужен к задаче.
Ответы (1)
Дана длина окружности. Найти площадь круга ограниченного этой окружностью. В качестве значения Pi использовать 3.14. Программа в паскале.
Ответы (1)
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)