Задать вопрос
23 октября, 20:56

Напишите программы на Паскале, используя цикл "Пока".

1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N.

2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.

+2
Ответы (1)
  1. 24 октября, 00:09
    0
    1)

    Program n1;

    var sum, n, i: integer;

    begin

    i:=1;

    sum:=0;

    readln (n) ;

    while i<=n do

    begin

    sum:=sum+i;

    i:=i+1;

    end;

    write (sum) ;

    end.

    2)

    Program n2;

    var x, n, i, z: integer;

    p: integer;

    begin

    readln (x, n) ;

    i:=0;

    p:=1;

    z:=1;

    if x<0 then z:=-1;

    x:=abs (x) ;

    while in do

    begin

    p:=p*x;

    i:=i+1;

    end;

    if (z=-1) and (i mod 2=0) then write (p) else if (z=-1) and (i mod 20) then write (-p) else write (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составь алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного с клавиатуры натурального числа N. Напиши программу на Паскале.
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. Программу напишите на Бейсике
Ответы (1)
Составьте алгоритм вычисления сумму всех натуральных чисел, не превышающих заданного натурального числа N. Проверьте алгоритм трассировкой.
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих данного заданного числа N. Напишите программу на Паскале. P. S. Тема урока - программирование циклов
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N. Проверьте алгоритм трассировкой. Напишите программу в Паскале.
Ответы (1)