Задать вопрос
20 января, 06:58

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

+3
Ответы (1)
  1. 20 января, 07:08
    0
    Const

    n = 40;

    var

    x: array[1 ... n] of integer;

    i, k, s: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    k : = 0; s : = 0;

    for i : = 1 to n do

    begin

    x[i] : = Random (50) ;

    Write (x[i]:3) ;

    end;

    Writeln;

    Writeln ('Элементы со значением в интервале [7; 10]') ;

    for i : = 1 to n do

    if (x[i] > = 7) and (x[i] < = 10) then

    begin

    k : = k + 1; s : = s + x[i];

    Write (x[i]:3)

    end;

    if k = 0 then Writeln ('не найдены')

    else Writeln (#13#10, ' Элементов:', k, ', среднее арифметическое=', s / k:5:3)

    end.

    Тестовое решение:

    Элементы массива

    24 33 36 29 12 7 5 36 3 48 40 40 46 6 10 23 33 3 38 48 29 37 11 40 44 16 17 18 34 38 33 39 9 0 41 37 42 2 40 31

    Элементы со значением в интервале [7; 10]

    7 10 9

    Элементов: 3, среднее арифметическое=8.667
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)