Задать вопрос
17 июля, 00:36

Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом)

p. s. В паскале

+4
Ответы (1)
  1. 17 июля, 00:42
    0
    Var

    n, i, s, k:integer;

    a:array [1 ... 30] of integer;

    begin

    writeln ('Vvedite massiv') ;

    for i:=1 to 30 do

    readln (a[i]) ;

    writeln ('Massiv') ;

    for i:=1 to 30 do

    write (a[i],' ') ;

    writeln () ;

    k:=0; s:=0;

    for i:=1 to 30 do

    if a[i]<0 then

    begin

    s:=a[i]+s;

    k:=1;

    end;

    if k=1 then

    writeln ('Summa otricatelnih elementov: ', s)

    else

    writeln ('Otricatelnih elementov net') ;

    readln () ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в предположении, что в массиве есть хотя бы 1 отрицательный элемент (Паскаль)
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)