Задать вопрос
3 ноября, 07:07

Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в предположении, что в массиве есть хотя бы 1 отрицательный элемент (Паскаль)

+3
Ответы (1)
  1. 3 ноября, 11:01
    0
    Var mas30: array [1 ... 30] of integer;

    var i, proz: integer;

    begin

    proz:=1;

    for i:=1 to 30 do begin mas30[i]:=-5+random (11) ; / / Заполнение массива

    write (mas30[i], ' ') ; / / вывод значений массива

    end;

    writeln;

    for i:=1 to 30 do if mas30[i]<0 then proz:=proz*mas30[i]; / / Подсчет произведения отриц элементов

    writeln (proz) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу подсчета произведения всех отрицательных элементов заданного целочисленного массива размером 30 элементов, в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом) p. s. В паскале
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)