Задать вопрос
27 января, 00:10

Составьте программу в Паскале для поиска:

a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры

b) произведения отрицательных элементов массива а от 1 до 100

c) количества нулевых элементов массива с сотней элементов

+1
Ответы (1)
  1. 27 января, 02:01
    0
    А) uses crt;

    const n=10;

    var a:array[1 ... n] of integer;

    i, sum:integer;

    begin

    for i:=1 to n do

    begin

    a[i]:=random (100) - 50;

    write (a[i]:4) ;

    if a[i]>0 then sum:=sum+a[i];

    end;

    writeln;

    writeln ('Сумма положительных элементов = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Дан массив целых чисел из N элементов, введенных с клавиатуры. Посчитать сколько в нем отрицательных, положительных и нулевых чисел?
Ответы (2)
Задание 1: Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива с нечетными значениями. Задание 2:Составьте программу ввода с клавиатуры массива целых чисел a[1 ...
Ответы (1)
С клавиатуры вводятся N чисел. Составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. Значение N и сами числа вводится с клавиатуры.
Ответы (2)