Задать вопрос
22 января, 04:15

Дан массив целых чисел из N элементов, введенных с клавиатуры. Посчитать сколько в нем отрицательных, положительных и нулевых чисел?

+3
Ответы (2)
  1. 22 января, 06:33
    0
    Var a:array of integer; x, y, z, n:integer; begin readln (n) ; setlength (a, n) ; for i:=0 to Length (a) do begin if a[i]>0 then x:=x=1; if a[i]<0 then y:=y+1; if a[i] = 0 then z:=z+1; end; write ('отрицательных=', x,' положительных=', y,' нулевых=', z) ; end.
  2. 22 января, 06:57
    0
    В C++

    #include

    int main ()

    {

    using namespace std;

    cout << "Enter N: ";

    int N;

    cin >> N;

    int * parr = new int[N];

    for (int i = 0; i < N; + + i)

    {

    cout << "Enter #" << i + 1 << " element: ";

    cin >> parr[i];

    }

    int kpos = 0, kneg = 0, kzer = 0;

    for (int i = 0; i < N; + + i)

    {

    if (parr[i] > 0)

    ++kpos;

    else if (parr[i] < 0)

    ++kneg;

    else

    ++kzer;

    }

    cout << "Number of positive: " << kpos

    << "/nNumber of negative: " << kneg

    << "/nNumber of zero: " << kzer << endl;

    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел из N элементов, введенных с клавиатуры. Посчитать сколько в нем отрицательных, положительных и нулевых чисел? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)