Задать вопрос
17 сентября, 06:30

Вычислить X=m / (n-m), где m - сумма квадратов отрицательных элементов первого вектора, n - сумма квадратов отрицательных элементов второго вектора в паскале

+1
Ответы (1)
  1. 17 сентября, 07:11
    0
    Const k=10;

    type arr=array[1 ... k] of integer;

    procedure p1 (var x:arr) ;

    var i:integer;

    begin

    for i:=1 to k do

    begin

    x[i]:=random (30) - 15;

    write (x[i]:3) ;

    end;

    writeln;

    end;

    function f1 (var x:arr) : integer;

    var i, s:integer;

    begin

    s:=0;

    for i:=1 to k do

    if x[i]<0 then s:=s+x[i]*x[i];

    f1:=s;

    end;

    var a, b:arr; m, n:integer; x:real;

    begin

    writeln ('a:') ;

    p1 (a) ;

    writeln ('b:') ;

    p1 (b) ;

    m:=f1 (a) ;

    n:=f1 (b) ;

    writeln ('m = ', m,' n = ', n) ;

    x:=m / (n-m) ;

    writeln ('x = ', x:6:4) ;

    end.

    Пример:

    a:

    -13 7-11 11 - 3 4 13 3 - 1 2

    b:

    8 - 2 5 10 9 8 - 8 12 7-13

    m = 300 n = 237

    x = - 4.7619
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить X=m / (n-m), где m - сумма квадратов отрицательных элементов первого вектора, n - сумма квадратов отрицательных элементов второго ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом) p. s. В паскале
Ответы (1)
Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов
Ответы (1)
Дан массив R1 ... R20. Определить номер первого и последнего отрицательных элементов. Вычислить сумму этих элементов В Паскале
Ответы (1)
Дана матрица А (4*5). Вычислить сумму квадратов всех ее отрицательных элементов. Кто сможет решите на паскале?
Ответы (1)
Написать программы на Паскале. 1. Вычислить. X - натуральное число. 2. Среди 10 введённых с клавиатуры чисел подсчитать количество отрицательных и произведение положительных. Рассмотреть случай если отрицательных чисел нет.
Ответы (1)