Задать вопрос
25 октября, 04:29

Дан массив R1 ... R20. Определить номер первого и последнего отрицательных элементов. Вычислить сумму этих элементов

В Паскале

+4
Ответы (1)
  1. 25 октября, 06:32
    0
    const N=20;

    var R:array[1 ... N] of integer;

    i, a, b, c, s:integer;

    begin

    a:=0;

    b:=0;

    for i:=1 to N do

    begin

    R[i]:=random (N) - random (N) ;

    write (R[i]:3,'[', i,']') ;

    end;

    writeln;

    for i:=1 to N do

    begin

    if a<1 then

    begin

    if R[i]<0 then

    begin

    b:=i;

    a:=a+1;

    end;

    end;

    end;

    a:=0;

    c:=0;

    for i:=N downto 1 do

    begin

    if a<1 then

    begin

    if R[i]<0 then

    begin

    c:=i;

    a:=a+1;

    end;

    end;

    end;

    s:=0;

    for i:=1 to N do

    s:=s+R[i];

    writeln ('Номер первого отрицательного элемента - ', b) ;

    writeln ('Номер последнего отрицательного элемента - ', c) ;

    writeln ('Сумма элементов в массиве - ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив R1 ... R20. Определить номер первого и последнего отрицательных элементов. Вычислить сумму этих элементов В Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)