Задать вопрос
29 января, 08:53

Дана матрица А (4*5). Вычислить сумму квадратов всех ее отрицательных элементов. Кто сможет решите на паскале?

+1
Ответы (1)
  1. 29 января, 11:37
    0
    Const

    m=4;

    n=5;

    var

    a:array[1 ... m, 1 ... n] of integer;

    i, j, s, e:integer;

    begin

    Randomize;

    s:=0;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    e:=Random (100) - 50;

    a[i, j]:=e;

    if e<0 then s:=s+sqr (e) ;

    write (e:4)

    end;

    writeln

    end;

    writeln ('Сумма квадратов отрицательных элементов равна ', s)

    end.

    Тестовое решение:

    43 - 12 - 47 27 34

    -47 - 44 - 38 47 - 5

    29 - 40 - 44 46 21

    -17 32 0 10 - 43

    Сумма квадратов отрицательных элементов равна 13641
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана матрица А (4*5). Вычислить сумму квадратов всех ее отрицательных элементов. Кто сможет решите на паскале? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить X=m / (n-m), где m - сумма квадратов отрицательных элементов первого вектора, n - сумма квадратов отрицательных элементов второго вектора в паскале
Ответы (1)
ПаскальАВС. №1. Вычислить сумму и число положительных элементов матрица А[N, N], находящихся над главной диагональю. №2. Дана вещественная матрица А размера n x m.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом) p. s. В паскале
Ответы (1)