Задать вопрос
5 июня, 15:28

найти максимальный диагональный элемент и указать его координаты в главной диагонали матрицы, помогите написать программу

+3
Ответы (1)
  1. 5 июня, 18:32
    0
    Uses crt; const h=100; var a: array [1 ... h, 1 ... h] of integer; n, x, y, max: integer;

    begin write ('Длина матрицы = ') ; readln (n) ; / / Enter for x:=1 to n do for y:=1 to n do begin write ('a[', x,',', y,'] = ') ; readln (a[x, y]) ; end; / / max:=a[1,1]; while xn do begin if a[x, x] > max then begin max:=a[x, x]; y:=x; end; inc (x) ; end; writeln ('Максимальный элемент равен ', max,'. Его координаты (', y,'; ', y,').') ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти максимальный диагональный элемент и указать его координаты в главной диагонали матрицы, помогите написать программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Разработать алгоритм и программу решения задачи: найти сумму отрицательных элементов двумерного массива находящихся на главной диагонали матрицы размером 10 х10 (с вводом и выводом матрицы)
Ответы (1)
Из матрицы У (k, k) получить вектор Т, элементами которого являются элементы главной диагонали матрицы. напишите программу в паскаль
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)