Задать вопрос
19 ноября, 10:21

Разработать алгоритм и программу решения задачи: найти сумму отрицательных элементов двумерного массива находящихся на главной диагонали матрицы размером 10 х10 (с вводом и выводом матрицы)

+5
Ответы (1)
  1. 19 ноября, 13:11
    0
    Var matrix: array[1 ... 5,1 ... 5] of integer; i, j: integer; sg:=0; sp:=0; begin writeln ('Введите 25 чисел: ') ; for i : = 1 to 5 do for j : = 1 to 5 do read (matrix[i, j]) ; for i : = 1 to 5 do begin for j : = 1 to 5 do write (matrix[i, j], ' ') ; writeln end; for i:=1 to 5 do begin for j: = 1 to 5 do if j=i then sg:=sg+matrix[i, j]; end; for i:=5 downto 1 do begin for j:=1to 5 do if (i+j) = 6 then sp:=sp+matrix[i, j] end; sp:=sp-matrix[3,3]; 1 writeln (sg,' ', sp) ; readln end
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Разработать алгоритм и программу решения задачи: найти сумму отрицательных элементов двумерного массива находящихся на главной диагонали ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти произведение элементов двумерного массива находящихся на главной диагонали матрицы размером (10*10), с вводом и выводом матрицы на Basic.
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
Нужно разработать программу для определения требуемых величин в элементах двумерного массива, расположенных ниже главной и побочной диагонали. Имя массива J Размер 32 Программа должна реализовывать следующие функции: 1. Сумма всех чисел 2.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)