Задать вопрос
18 мая, 08:49

Нужно разработать программу для определения требуемых величин в элементах двумерного массива, расположенных ниже главной и побочной диагонали.

Имя массива J

Размер 32

Программа должна реализовывать следующие функции:

1. Сумма всех чисел

2. минимальное чётное число

3. кол-во отрицательных нечётных чисел

4. сумма отрицательных нечетных чисел

+4
Ответы (1)
  1. 18 мая, 12:06
    0
    Var

    J: Array[1 ... 32,1 ... 32] Of Integer;

    i, j, S: Integer;

    Begin

    //заводим массив

    For i:=1 to 32 do

    For j:=1 to 32 do

    begin

    Writeln ("Введите J[", i,",", j,"]") ;

    Readln (J[i, j]) ;

    End;

    //Сумма всех чисел

    S:=0;

    For i:=1 to 32 do

    For j:=1 to 32 do

    S:=S + J[i, j];

    Writeln ("Сумма всех чисел = ", S) ;

    S = 0;

    //Минимальное четное число

    For i:=1 to 32 do

    For j:=1 to 32 do

    If (J[i, j] mod 2 = 0) And (J[i, j]
    Writeln ("Минимальное четное число = ", S) ;

    S:=0;

    //кол-во отрицательных нечетных чисел

    For i:=1 to 32 do

    For j:=1 to 32 do

    If (J[i, j] mod 2 0) And (J[i, j] <0) Then S: = S+1;

    Writeln ("кол-во отрицательных нечетных чисел = ", S) ;

    S:=0;

    //сумма отрицательных нечетных чисел

    For i:=1 to 32 do

    For j:=1 to 32 do

    If (J[i, j] mod 2 0) And (J[i, j] <0) Then S: = S+J[i, j];

    Writeln ("сумма отрицательных нечетных чисел = ", S) ;

    End;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно разработать программу для определения требуемых величин в элементах двумерного массива, расположенных ниже главной и побочной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное число. Программа получает на вход кол-во чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)