Задать вопрос
1 мая, 13:42

Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное число.

Программа получает на вход кол-во чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число. Кол-во чисел не превышает 1000. Введеные числа не превышают 30000.

Программа должна вывести одно число - минимальное четное число.

Паскаль

+5
Ответы (1)
  1. 1 мая, 17:19
    0
    Var

    a, m, k, i: integer;

    begin

    write ('Введите количество чисел в последовательности: ') ;

    readln (k) ;

    m:=30000; / / / Максимальное чётное число

    for i : = 1 to k do

    begin

    write ('Введите число: ') ;

    readln (a) ;

    if (a mod 2 = 0) and (m>a) then m:=a

    end;

    writeln ('Минимальное четное число в последовательности: ', m)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное число. Программа получает на вход кол-во ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Задача 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)