Задать вопрос
1 апреля, 22:41

Из матрицы У (k, k) получить вектор Т, элементами которого являются элементы главной диагонали матрицы. напишите программу в паскаль

+5
Ответы (1)
  1. 2 апреля, 01:52
    0
    Const n=4;

    var y : array[1 ... n, 1 ... n] of integer;

    t : array[1 ... n] of integer;

    i, j : integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    y[i, j]:=random (20) - 10;

    write (y[i, j]:4) ;

    end;

    writeln;

    end;

    for i:=1 to n do t[i]:=y[i, i];

    writeln ('Полученный массив:') ;

    for i:=1 to n do write (t[i]:5) ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Из матрицы У (k, k) получить вектор Т, элементами которого являются элементы главной диагонали матрицы. напишите программу в паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Что будет написано после выполнения алгоритма? алг буква_1 нач опустить перо сместиться на вектор (0, 4) сместиться на вектор (1, - 2) сместиться на вектор (1, 2) сместиться на вектор (0, - 4) поднять перо сместиться на вектор (1, 0) кон алг буква_2
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Дан массив Х (N, N). Найти количество положительных элементов матрицы, лежащих на главной диагонали (элементы главной диагонали с индексами (1,1), (2,2) и т. д.) Паскаль
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)