Задать вопрос
25 апреля, 06:42

Составить легкую программу!

Зеркально отразить последовательность в одномерном массиве.

Т. е. Задаем последовательность, вводим границы "зеркала" - х и у. И зеркально отражаем.

Пример: 12345678910

х=5

у=8

Вывод: 12348765910.

Очень буду блгодарна!

+5
Ответы (2)
  1. 25 апреля, 07:40
    0
    var a: array [1 ... 10] of integer;

    i, x, y, xi, yi, t: integer;

    begin

    for i : = 1 to 10 do

    readln (a[i]) ;

    writeln ('X, Y') ;

    readln (X, Y) ;

    for i : = 0 to abs (round (0.5 * (x-y))) do

    begin

    t : = a[x+i];

    a[x+i] : = a[y-i];

    a[y-i] : = t;

    end;

    for i : = 1 to 10 do

    writeln ('[', i, '] = > ', a[i]) ;

    end.
  2. 25 апреля, 09:46
    0
    Вот, пингвинчик: 3 Можно было и короче, переменных поменьше и циклов ... Но раз задача именно такая, то лучше не сокращать, а то могут оценку снизить)

    var a: array [1 ... 10] of integer;

    i, x, y, xi, yi, t: integer;

    begin

    for i : = 1 to 10 do

    readln (a[i]) ;

    writeln ('X, Y') ;

    readln (X, Y) ;

    for i : = 1 to 10 do

    begin

    if (a[i] = X) then xi : = i;

    if (a[i] = Y) then yi : = i;

    end;

    t : = a[xi];

    a[xi] : = a[yi];

    a[yi] : = t;

    for i : = 1 to 10 do

    writeln ('[', i, '] = > ', a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить легкую программу! Зеркально отразить последовательность в одномерном массиве. Т. е. Задаем последовательность, вводим границы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.
Ответы (1)