Задать вопрос
30 апреля, 17:27

Прошу, помогите написать программу!

(Тема - Операции над массивами.)

Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.

+3
Ответы (1)
  1. 30 апреля, 19:10
    0
    Const n=10;

    var a:array [1 ... n] of integer;

    k, i:integer;

    begin

    writeln ('vvedite massiv = ') ;

    for i : = 1 to n do

    readln (a[i]) ;

    k:=0;

    for i : = 1 to n do

    if a[i]>0 then inc (k) ;

    writeln ('k=', k) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры, находит количество элементов больших заданного числа.
Ответы (1)
Написать программу, которая в одновременном массиве заданным вводом данных с клавиатуры находит индекс максимального элемента массива. На языке Pascal.
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)