Задать вопрос
28 марта, 17:32

Написать программу, которая в одновременном массиве заданным вводом данных с клавиатуры находит индекс максимального элемента массива. На языке Pascal.

+1
Ответы (1)
  1. 28 марта, 20:17
    0
    Var n, i, max:integer;

    a:array [1 ... 1000] of integer; //объявляем массив

    begin

    writeln ('Введите количество чисел') ;

    readln (n) ;

    for i:=1 to n do begin

    readln (a[i]) ;

    if a[i]>max then

    max:=i;

    end;

    writeln ('Индекс максимального элемента массива = ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая в одновременном массиве заданным вводом данных с клавиатуры находит индекс максимального элемента массива. На ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.
Ответы (1)
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры, находит количество элементов больших заданного числа.
Ответы (1)