Задать вопрос
6 сентября, 08:48

1. определить, есть ли среди цифр заданного трехзначного числа одинаковые.

2. вычислить стоимость покупки с учетом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 руб.

+4
Ответы (1)
  1. 6 сентября, 09:40
    0
    1) uses crt; var x, a, b, c, i: integer; begin cls; write ('Введите число: ') ; readln (x) ; a: = x div 100; b: = (x - a*100) div 10; c: = (x - a*100 - b*10) ; if (a=b) or (a=c) or (b=c) then writeln ('Есть одинаковые цифры') else writeln ('Одинаковых цифр нет') ; end.

    2) uses crt; var x: real; begin cls; write ('Сумма покупки: ') ; readln (x) ; if x>1000 then x:=x - (x*0.1) ; writeln ('Стоимость с учётом возможной скидки ', x) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. определить, есть ли среди цифр заданного трехзначного числа одинаковые. 2. вычислить стоимость покупки с учетом скидки. Скидка в 10% ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей.
Ответы (1)
Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется, если сумма покупки больше 500 руб, в 5% - если сумма больше 1000 руб. Фрагмент программы: if x>500 then y:=0.
Ответы (1)
Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. (Pascal)
Ответы (1)
Составить мат. модель, алгоритм, программу для решения следующей задачи: Найти стоимость покупки с учетом скидки. Скидка в 10 % предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)