Задать вопрос
23 февраля, 08:28

Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется, если сумма покупки больше 500 руб, в 5% - если сумма больше 1000 руб. Фрагмент программы: if x>500 then y:=0.97*x; if x>1000 then y:=0.95*x;

+1
Ответы (1)
  1. 23 февраля, 08:45
    0
    var

    x: real;

    begin

    readln (x) ;

    if (x > 500) then x : = 0.97 * x

    else if (x > 1000) then x : = 0.95 * x;

    writeln ('Стоимость покупки с учетом скидки: ', x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется, если сумма покупки ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы