Задать вопрос
17 января, 12:45

Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей. В результате вывести итоговую стоимость покупки и размер предоставленной скидки.

+5
Ответы (1)
  1. 17 января, 14:49
    0
    Var s:integer;

    begin

    write ('Стоимость покупки = ') ; readln (s) ;

    if s>1000

    then writeln ('Скидка 5% (', s*0.05,' руб.), необходимо заплатить ', s*0.95)

    else if s>500

    then writeln ('Скидка 3% (', s*0.03,' руб.), необходимо заплатить ', s*0.97)

    else writeln ('Скидки нет') ;

    end.

    Пример:

    Стоимость покупки = 600

    Скидка 3% (18 руб.), необходимо заплатить 582
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)
Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести "скидка 5%", если стоимость свыше 5000, то вывести "скидка 10%". Вывести сумму со скидкой.
Ответы (1)
Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. (Pascal)
Ответы (1)
Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется, если сумма покупки больше 500 руб, в 5% - если сумма больше 1000 руб. Фрагмент программы: if x>500 then y:=0.
Ответы (1)
Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 руб
Ответы (1)