Задать вопрос
24 октября, 03:56

Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести "скидка 5%", если стоимость свыше 5000, то вывести "скидка 10%". Вывести сумму со скидкой.

+3
Ответы (1)
  1. 24 октября, 07:52
    0
    Для Paskal ABC

    Program magazin;

    var

    a:integer;

    s:integer;

    begin

    s:=0;

    writeln ('Введите стоимость:') ;

    readln (a) ;

    If a<1000 then begin

    writeln ('Скидок нет') ;

    writeln ('Ваша сумма:', a) ; end;

    If (a>=1000) and (a<=5000) then begin

    s: = (a/100) * 95;

    writeln ('Ваша скидка 5%') ;

    writeln ('Ваша сумма:', s) ; end;

    If a>5000 then begin

    s: = (a/100) * 90;

    writeln ('Ваша скидка 10%') ;

    writeln ('Ваша сумма:', s) ; end;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В магазине проводится акция при сумме покупки больше 1000 р, предлагается скидка 10%. Ввести сумму покупки, вывести; 1) сообщение о том, предоставляется ли скидка 2) сумму к оплате Написать программу в паскале
Ответы (1)
через паскаль 1 ввести 3 числа, вывести наименьшее 2 ввести номер месяца, вывести название месяца 3 ввести 5 чисел, вывести в порядке убывания
Ответы (1)
1) Ввести число. Если оно неотрицательно (больше 0), вычесть из него 10, иначе - прибавить к нему 10 2) Ввести 2 числа.
Ответы (1)
Напишите на языке C++! 1) Ввести число. Если оно неотрицательно (больше 0), вычесть из него 10, иначе - прибавить к нему 10 2) Ввести 2 числа.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)