Задать вопрос
26 октября, 07:11

В магазине проводится акция при сумме покупки больше 1000 р, предлагается скидка 10%. Ввести сумму покупки, вывести;

1) сообщение о том, предоставляется ли скидка

2) сумму к оплате

Написать программу в паскале

+3
Ответы (1)
  1. 26 октября, 07:58
    0
    Var s:real;

    begin

    write ('Сумма покупки = ') ;

    readln (s) ;

    if s>1000

    then writeln ('Предоставляется скидка 10%. Сумма к оплате = ', s*0.9)

    else writeln ('Скидка не предоставляется. Сумма к оплате = ', s) ;

    end.

    Пример:

    Сумма покупки = 2000

    Предоставляется скидка 10%. Сумма к оплате = 1800
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В магазине проводится акция при сумме покупки больше 1000 р, предлагается скидка 10%. Ввести сумму покупки, вывести; 1) сообщение о том, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести стоимость покупки в магазине, если стоимость меньше тысячи, то вывести "скидки нет", если стоимость от 1000 до 5000, то вывести "скидка 5%", если стоимость свыше 5000, то вывести "скидка 10%". Вывести сумму со скидкой.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей.
Ответы (1)
Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. (Pascal)
Ответы (1)
через паскаль 1 ввести 3 числа, вывести наименьшее 2 ввести номер месяца, вывести название месяца 3 ввести 5 чисел, вывести в порядке убывания
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)