Задать вопрос
24 июля, 09:44

1) Ввести число. Если оно неотрицательно (больше 0), вычесть из него 10,

иначе - прибавить к нему 10

2) Ввести 2 числа. Если их произведение отрицательно, умножить его на

-2 и вывести на экран, иначе - увеличить его в 3 раза и вывести на

экран

3) Ввести два числа. Вычесть из большего меньшее

4) Ввести рост человека. Вывести на экран "высокий", если его рост

превышает 180 см, "нормальный" и "низкий".

+4
Ответы (1)
  1. 24 июля, 13:19
    0
    1.

    var a:integer;

    begin

    write ('Введите число: ') ;

    readln (a) ;

    if a>0 then a:=a-10 else a:=a+10;

    writeln ('a = ', a) ;

    end.

    Пример:

    Введите число: 5

    a = - 5

    2.

    var a, b, p:integer;

    begin

    writeln ('Введите два числа: ') ;

    readln (a, b) ;

    if a*b<0 then p:=-2*a*b else p:=3*a*b;

    writeln ('p = ', p) ;

    end.

    Пример:

    Введите два числа:

    -3 - 8

    p = 72

    3.

    var a, b, r:integer;

    begin

    writeln ('Введите два числа: ') ;

    readln (a, b) ;

    if a>b then r:=a-b else r:=b-a;

    writeln ('r = ', r) ;

    end.

    Пример:

    Введите два числа:

    25 48

    r = 23

    4.

    var r:integer;

    begin

    writeln ('Введите рост: ') ;

    readln (r) ;

    if r>180

    then writeln ('высокий')

    else if r=180 then writeln ('нормальный') else writeln ('низкий') ;

    end.

    Пример:

    Введите рост:

    160

    низкий
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Ввести число. Если оно неотрицательно (больше 0), вычесть из него 10, иначе - прибавить к нему 10 2) Ввести 2 числа. Если их ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите на языке C++! 1) Ввести число. Если оно неотрицательно (больше 0), вычесть из него 10, иначе - прибавить к нему 10 2) Ввести 2 числа.
Ответы (1)
Ввести рост человека (в см) если его рост превышает 180 см, то вывести на экран сообщение "высокий" иначе вывести сообщение "не очень высокий"
Ответы (1)
Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Написать на языке Packal
Ответы (1)
Составить программу. Ввести 2 числа, если их произведение отрицательно, то умножить его на - 2 и вывести на экран, если нет, то увеличить его в 3 раза и вывести на экран.
Ответы (1)
Ввести 2 числа. Если их произведение отрицательно, умножить его на 2 и вывести на экран, в противном случае увеличить его в 1,5 раза и вывести на экран.
Ответы (1)