Задать вопрос
16 декабря, 03:56

С клавиатуры вводится строка. С новой строки

вводится буква. Составьте

программу подсчета количества заданных букв в заданной строке.

Определить, является

ли длина введенного слова числом, кратным трем.

Определить,

заканчивается ли введенное слово гласной буквой.

+5
Ответы (1)
  1. 16 декабря, 07:37
    0
    Var

    s : string;

    c : char;

    i, a : integer;

    begin

    readln (s) ;

    read (c) ;

    a : = 0;

    for i : = 1 to length (s) do if s[i] = c then a : = a + 1;

    write (a) ;

    end.

    var

    s : string;

    begin

    readln (s) ;

    if length (s) mod 3 = 0 then write ('YES') else write ('NO') ;

    end.

    var

    s : string;

    begin

    readln (s) ;

    if s[length (s) ] in ['а', 'о', тут через запятую гласные] then write ('YES') else write ('NO') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится строка. С новой строки вводится буква. Составьте программу подсчета количества заданных букв в заданной строке. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Паскаль 1) Задана строка, проверить есть ли в этой строке буква "а" 2) задана строка, проверить сколько раз встречаться в этой строке буква "м" 3) задана строка, удалить из этой строки все буквы "и"
Ответы (1)
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
На паскале Даны две строки. Определите, является ли первая строка подстрокой второй строки. Входные данные На вход подается 2 строки длины не более 10000, состоящие только из маленьких букв латинского алфавита.
Ответы (2)