Задать вопрос
5 октября, 17:22

На паскале

Даны две строки. Определите, является ли первая строка подстрокой второй строки.

Входные данные

На вход подается 2 строки длины не более 10000, состоящие только из маленьких букв латинского алфавита.

Выходные данные

Необходимо вывести слово yes, если первая строка является подстрокой второй строки, или слово no в противном случае.

Примеры

входные данные

abac

ababacaba

выходные данные

yes

+5
Ответы (2)
  1. 5 октября, 18:09
    0
    Program ABC;

    var s, p: string;

    begin

    writeln ('Введите 1 строку:') ;

    readln (s) ;

    writeln ('Введите 2 строку:') ;

    readln (p) ;

    if (pos (s, p) 0) then

    writeln ('Yes')

    else

    writeln ('No') ;

    end.
  2. 5 октября, 19:24
    0
    Var S, S1:string;

    Begin

    ReadLn (S) ;

    ReadLn (S1) ;

    if Pos (S, S1) 0 then WriteLn ('yes')

    else WriteLn ('no')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На паскале Даны две строки. Определите, является ли первая строка подстрокой второй строки. Входные данные На вход подается 2 строки длины ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
В кафе мороженое продают по три шарика и по пять шариков. Можно ли купить ровно k шариков мороженого? Входные данные Вводится число k (целое, положительное) Выходные данные Программа должна вывести слово YES, если при таких условиях можно набрать
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)