Задать вопрос
14 ноября, 22:01

Найти максимальный элемент дополнительной диагонали квадратной матрицы (в паскале)

+5
Ответы (1)
  1. 14 ноября, 22:35
    0
    Var a:array[1 ... 8, 1 ... 8] of integer;

    max, i, j:integer;

    begin

    randomize;

    max:=0;

    for i:=1 to 8 do

    for j:=1 to 8 do

    a[i, j]:=random (200) ;

    for i:=1 to 8 do

    for j:=1 to 8 do

    if i+j=9 then

    begin

    if a[i, j]>max then max:=a[i, j];

    end;

    for i:=1 to 8 do

    begin

    for j:=1 to 8 do

    write (a[i, j]:5) ;

    writeln;

    end;

    writeln ('Максимальный элемент=', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти максимальный элемент дополнительной диагонали квадратной матрицы (в паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)
Помогите решить задачку (Паскаль) Дана матрица B (4,4) 1) Найти произведение положительных элементов среди элеметов рассположенных выше побочной диагонали матрицы B. 2) Найти минимальный элемент во втором столбце матрицы B.
Ответы (1)
Задачка в паскале. В двумерном массиве G (7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице вычислить значение произведения элементов главной диагонали.
Ответы (1)