Задать вопрос
4 декабря, 22:59

Помогите решить задачку (Паскаль)

Дана матрица B (4,4)

1) Найти произведение положительных элементов среди элеметов рассположенных выше побочной диагонали матрицы B.

2) Найти минимальный элемент во втором столбце матрицы B.

3) Поменять местами найденный минимальный эелемент и значение третьего элемента в четвертой строке.

+2
Ответы (1)
  1. 5 декабря, 00:07
    0
    Uses crt;

    const n=4;

    var b:array[1 ... n, 1 ... n] of integer;

    i, j, pr, k, t, min:integer;

    begin

    randomize;

    pr:=1;

    for i:=1 to n do

    for j:=1 to n do

    b[i, j]:=random (100) - 50;

    for i:=1 to n do

    begin

    for j:=1 to n do

    write (b[i, j]:3) ;

    writeln;

    end;

    writeln;

    k:=1;

    t:=3;

    repeat

    for i:=k to k do

    for j:=1 to t do

    if b[i, j]>0 then pr:=b[i, j]*pr;

    inc (k) ;

    t:=t-1;

    until k=4;

    writeln (pr) ;

    min:=50;

    for i:=1 to n do

    for j:=2 to 2 do

    if b[i, j]
    writeln (min) ;

    writeln;

    b[4,3]:=b[4,3]+b[k, t];

    b[k, t]:=b[4,3]-b[k, t];

    b[4,3]:=b[4,3]-b[k, t];

    for i:=1 to n do

    begin

    for j:=1 to n do

    write (b[i, j]:3) ;

    writeln;

    end;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачку (Паскаль) Дана матрица B (4,4) 1) Найти произведение положительных элементов среди элеметов рассположенных выше ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Pascal. Дана целочисленная квадратная матрица. Найти в каждой строке наибольший элемент и поменять его местами с элементом главной диагонали в этой же строке
Ответы (1)
Помогите написать программу в pascal'e. Если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали. В противном случае-заменить элементы четных строк нулями.
Ответы (1)