Задать вопрос
3 апреля, 01:29

А) найдите среднюю температуру за неделю (температура была: - 5, - 3, - 7, - 6, - 2, - 4, - 3) Сколько дней было выше средней? Ниже средней? составить массив.

+2
Ответы (1)
  1. 3 апреля, 05:23
    0
    Program Frank;

    const n=7;

    Type mas=array[1 ... n] of integer;

    var a:mas; i, sym, k, k1:integer; sredn:real;

    begin

    k:=0;

    k1:=0;

    a[1]:=-5;

    a[2]:=-3;

    a[3]:=-7;

    a[4]:=-6;

    a[5]:=-2;

    a[6]:=-4;

    a[7]:=-3;

    sym:=0;

    for i:=1 to n do begin

    sym:=sym+a[i];

    end;

    sredn:=sym/n;

    for i:=1 to n do begin

    if a[i]>sredn then k:=k+1

    else if a[i]
    end;

    writeln ('Кол-во дней, когда температура была выше средней ', k) ;

    writeln ('Кол-во дней, когда температура была ниже средней ', k1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «А) найдите среднюю температуру за неделю (температура была: - 5, - 3, - 7, - 6, - 2, - 4, - 3) Сколько дней было выше средней? Ниже ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан массив температура за ноябрь. Определить: Сколько дней температура была положительной? Вывести номера всех дней, когда температура была ниже 5 и выше 18 градусов. Кол-во дней в месяце и массив температуру ввести с клавиатуры.
Ответы (1)
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
В многострочном текстовом поле содержится значения средней температуры воздуха каждого дня недели (Числа вводятся с клавиатуры). Определите среднюю температуру воздуха за всю неделю. Выясните, сколько раз в неделю температура была выше нуля.
Ответы (1)
С клавиатуры вводится температура 7 дней недели. Распечатать в виде: один день недели-температура. Найти среднюю температуру недели, среднюю положительную и среднюю отрицательную. Использовать random от - 3 до 3
Ответы (1)
Составьте программу для ввода и вывода температуры за неделю. Результат может быть таким: 1 сентября температура была 17 2 сентября температура была 15 3 сентября температура была 16 4 сентября температура была 19
Ответы (1)