Задать вопрос
18 августа, 20:56

Pascal. Дана целочисленная квадратная матрица. Найти в каждой строке наибольший элемент и поменять его местами с элементом главной диагонали в этой же строке

+3
Ответы (1)
  1. 18 августа, 22:20
    0
    Const

    maxn = 100;

    type

    myarr = array [1 ... maxn, 1 ... maxn] of longint;

    var

    a: myarr;

    n, i, j, max, ini, c: longint;

    begin

    readln (n, m) ;

    for i : = 1 to n do begin

    max : = - maxInt;

    for j : = 1 to m do begin

    read (a[i, j]) ;

    if (a[i, j] > max) then begin

    max : = a[i, j];

    ini : = j;

    end;

    end;

    c : = a[i, i];

    a[i, i] : = max;

    a[i, ini] : = c;

    end;

    for : = 1 to n do begin

    for j : = 1 to m do

    write (a[i, j], ' ') ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. Дана целочисленная квадратная матрица. Найти в каждой строке наибольший элемент и поменять его местами с элементом главной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
помогите люди)). Дана квадратная целочисленная матрица размера 4 х4. Заменить нулями элементы матрицы, лежащие на главной диагонали. В bordland paskal. задача на двумерный массив
Ответы (1)
Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ему элемент исходной матрицы меньше элемента, расположенного в его строке на главной диагонали, и равен нулю в
Ответы (1)
Написать программу для "Pascal": Дана целочисленная матрица размерности (NxM). Поменять местами строки с max и min элементами.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)