Задать вопрос
13 февраля, 15:38

Написать программу для "Pascal":

Дана целочисленная матрица размерности (NxM). Поменять местами строки с max и min элементами.

+3
Ответы (1)
  1. 13 февраля, 18:13
    0
    Program n1;

    const maxm = 50;

    maxn = 50;

    var a:array[1 ... maxm, 1 ... maxn] of integer;

    min, max, i, j, n, m, x, maxi, mini:integer;

    begin

    write ('Введите размеры матрицы (N*M) : ') ;

    readln (n, m) ;

    writeln ('Введите матрицу из ', n,' строк и ', m,' столбцов:') ;

    min:=maxint; max:=-maxint-1;

    for i:=1 to n do

    for j:=1 to m do

    begin

    read (a[i, j]) ;

    if a[i, j]>max then begin max:=a[i, j]; maxi:=i; end;

    if a[i, j]
    end;

    for j:=1 to m do

    begin

    x:=a[maxi, j]; a[maxi, j]:=a[mini, j]; a[mini, j]:=x;

    end;

    writeln ('Матрица после преобразования:') ;

    for i:=1 to n do

    begin

    for j:=1 to m do

    write (a[i, j],' ') ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для "Pascal": Дана целочисленная матрица размерности (NxM). Поменять местами строки с max и min элементами. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы