Задать вопрос
6 января, 15:34

Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ему элемент исходной матрицы меньше элемента, расположенного в его строке на главной диагонали, и равен нулю в противном случае.

+4
Ответы (1)
  1. 6 января, 17:47
    0
    Const

    n = 9;

    var

    a: array[1 ... n, 1 ... n] of integer;

    i, j, aii: integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i : = 1 to n do

    begin

    for j : = 1 to n do

    begin

    a[i, j] : = Random (101) - 50;

    Write (a[i, j]:4)

    end;

    Writeln

    end;

    Writeln ('Результирующий массив') ;

    for i : = 1 to n do

    begin

    aii:=a[i, i];

    for j:=1 to n do

    begin

    if a[i, j]
    Write (a[i, j]:4)

    end;

    Writeln

    end

    end.

    Тестовое решение:

    Исходный массив

    -11 19 48 32 - 6 - 39 - 45 - 13 - 27

    44 20 - 44 27 - 50 14 - 19 - 12 32

    2 48 - 16 40 - 8 - 38 35 - 15 41

    -1 - 24 - 18 35 - 49 - 11 22 - 4 - 1

    36 - 26 - 8 - 2 - 9 - 17 41 44 - 13

    0 - 25 - 6 - 35 - 18 - 6 - 28 46 44

    5 - 1 - 23 36 47 - 41 - 30 7 - 39

    41 - 41 19 17 - 45 5 - 35 - 4 - 36

    -11 - 46 6 - 50 49 - 2 26 - 15 - 40

    Результирующий массив

    0 0 0 0 0 1 1 1 1

    0 0 1 0 1 1 1 1 0

    0 0 0 0 0 1 0 0 0

    1 1 1 0 1 1 1 1 1

    0 1 0 0 0 1 0 0 1

    0 1 0 1 1 0 1 0 0

    0 0 0 0 0 1 0 0 1

    0 1 0 0 1 0 1 0 1

    0 1 0 1 0 0 0 0 0
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана квадратная матрица 9-ого порядка. Получить квадратную матрицу того же порядка, в которой элемент равен единице, если соответствующий ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Оформить в виде подпрограмм-процедур в программе Pascal: Дана матрица действительных чисел M*N. Найти матрицу того же порядка, в которой элемент равен 1, если соответствующий ему элемент начальной матрицы больше, чем элемент, расположенный в его
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Pascal. Дана целочисленная квадратная матрица. Найти в каждой строке наибольший элемент и поменять его местами с элементом главной диагонали в этой же строке
Ответы (1)