Задать вопрос
8 апреля, 05:57

Задачка в паскале.

В двумерном массиве G (7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице вычислить значение произведения элементов главной диагонали. Заменить значение третьего элемента в первой строке на значение произведения.

+5
Ответы (1)
  1. 8 апреля, 06:29
    0
    Const

    n = 7;

    m = 5;

    var

    a: array[1 ... n, 1 ... m] of integer;

    min2_j, max5_i, i, j, p: integer;

    c: char;

    begin

    min2_j : = 1;

    max5_i : = 1;

    for i : = 1 to n do

    begin

    writeln;

    for j : = 1 to m do

    begin

    a[i, j] : = random (50) ;

    write (a[i, j]:n) ;

    if (i = 2) and (a[2, min2_j] > a[i, j]) then

    min2_j : = j;

    if (j = 5) and (a[max5_i, 5] < a[i, j]) then

    max5_i : = i;

    end;

    end;

    i : = a[2, min2_j];

    a[2, min2_j] : = a[max5_i, 5];

    a[max5_i, 5] : = i;

    writeln;

    p : = 1;

    for i : = 1 to n do

    begin

    writeln;

    for j : = 1 to m do

    begin

    write (a[i, j]:n) ;

    if (i = j) then

    p : = p * a[i, j];

    end;

    end;

    a[1, 3] : = p;

    writeln;

    for i : = 1 to n do

    begin

    writeln;

    for j : = 1 to m do

    write (a[i, j]:n) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задачка в паскале. В двумерном массиве G (7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
В двумерном массиве 7 Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали. Определить минимальный элемент главной диагонали (значение и координаты)
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)