Задать вопрос
31 декабря, 05:50

В двумерном массиве 7 Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали. Определить минимальный элемент главной диагонали (значение и координаты)

+2
Ответы (1)
  1. 31 декабря, 06:52
    0
    Const

    n = 7;

    var

    a: array[1 ... n, 1 ... n] of integer;

    i, j, sum, min, imin: integer;

    begin

    Randomize;

    for i : = 1 to n do

    for j : = 1 to n do

    a[i, j] : = random (100) - 50;

    writeln ('Исходный массив') ;

    for i : = 1 to n do

    begin

    for j : = 1 to n do write (a[i, j]:4) ;

    writeln

    end;

    sum : = 0;

    min : = 100; / / у нас в массиве числа на (-50:50)

    for i : = 1 to n - 1 do

    for j : = 1 to n - i do

    sum : = sum + a[i, j];

    for i : = 1 to n do

    if min > a[i, i] then begin

    min : = a[i, i];

    imin : = i

    end;

    writeln ('Сумма элементов левее побочной диагонали=', sum) ;

    writeln ('Минимальный элемент на главной диагонали=', min, ', его координаты (', imin, ',', imin, ') ')

    end.

    Контрольный пример:

    Исходный массив

    14 39 - 7 - 26 10 - 33 9

    48 - 21 - 19 6 2 24 - 16

    27 - 41 - 26 - 7 16 - 27 - 34

    42 32 - 12 - 37 - 9 20 - 26

    -35 - 20 - 34 40 - 3 5 1

    23 31 - 11 - 9 26 - 28 25

    34 26 - 30 11 43 19 - 26

    Сумма элементов левее побочной диагонали=-4

    Минимальный элемент на главной диагонали=-37, его координаты (4,4)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве 7 Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали. Определить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Задачка в паскале. В двумерном массиве G (7,5) поменять минимальный элемент 2 строки и максимальный элемент 5 столбца. В полученной матрице вычислить значение произведения элементов главной диагонали.
Ответы (1)
Паскаль. В двумерном массиве найти сумму элементов главной и побочной диагонали, элемент, находящийся в центре должен быть посчитан лишь один раз. Нужно написать программу.
Ответы (1)